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This data pack provides detailed installation and operation information for the Avenue
Logo application for use with the Avenue 5420 Digital Logo Inserter module as part of
the Avenue Signal Integration System.
The Avenue Logo information in this data pack is organized into the following sections:
•
•
•

•
•

Avenue Logo Overview
Installation
Using Avenue Logo
• Main Screen Overview
• Creating Logos
• Adjusting Crop Settings
• Adjusting Key Settings
• Creating, Saving and Loading Projects
Downloading to the 5420 Module
Help Menu
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AVENUE LOGO OVERVIEW
The Avenue Logo application accompanies the 5420 Digital Logo Inserter module. It allows
you to collect and configure graphic images created with any graphic program, save them
as a project file, then download them to the 5420 module for use as graphic and animation
sequence logos. The 5420 Digital Logo Inserter module allows the keying (insertion) of a
graphic image or animation sequence over a serial digital program background in either
DSK or Fill/Key mode.
Graphic stills, logos and animation sequences can be authored in targa format with a
graphics application. The stills, logos and animation sequences are then collected and
named with the Avenue Logo application. They can be saved in groups as a project file in
Avenue Logo. The project files can then be downloaded to flash memory on the 5420
module using Avenue Logo and a serial or Ethernet connection.
Each image is stored in flash memory, which can store up to 5 full frame images or many
smaller images, depending on their size. Total available storage is about 2 M pixels or
8 MB. An average corner logo is approximately 100 x 100 pixels in size for a total area of
about 10,000 pixels, allowing the 5420 to store up to 200 average size logos. Each frame in
an animation sequences is considered one logo. Animation sequences can be up to 200
frames long (approximately 6.5 seconds in 525 mode).
Each logo can be defined by number, name, type and can be positioned horizontally and
vertically on an image-by-image basis using Avenue Logo or the Avenue remote control
system. A density control allows changing the transparency of the key. These values are
then stored in memory on the module for each logo. In and out transition times can also be
programmed for each image in the remote control menus.
Images can be defined as events with the Avenue remote control menus then cut or mixed
on manually or triggered to come on by GPI control from an external control device,
including the Avenue 5815 GPI Control Panel. Up to eight events can be defined to correspond to the eight GPI inputs available on the Control connector on the rear of the
module.

INSTALLATION
To install Avenue Logo, insert the CD included with your 5420 module into the CD-ROM
drive of a PC connected to the Avenue network. Double-click the Avenue Logo setup icon to
run the installer.
Note the following cautions before using Avenue Logo:
•

Do not upload to the 5420 module while the module is on-air.

•

Uploading a new project file to the 5420 module will erase the currently loaded
project file loaded in flash memory.
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USING AVENUE LOGO
Double-click the Avenue Logo icon to open the application. The main screen appears.

Main Screen Overview
The main screen allows you to view and adjust a single targa image or an animation
sequence. If the graphic is composed of a key and fill, the separate components can be
viewed to the left of the screen in the Fill and Key windows. Key parameters can be
adjusted and previewed using the Adjust Crop Settings and Adjust Key Settings
controls.
Animation sequences can be viewed in real time by selecting the Show Animation box.
The type of animation sequence can be defined with the Cycle control and the number of
files in the animation sequence is shown in the Count box.
The graphic or animation can be defined as a logo by Logo number (1-999) and named by
typing in a unique name in the Logo Name box. This logo name will then appear in the
5420 menus.
As you define logos as part of a project, the Memory Used bar indicator will show the
percentage of memory space available in the 5420 module flash memory where the logos
are stored.

Avenue Logo Main Screen
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You can adjust the density of the image and its position on the screen using the slider
controls provided or by entering a value into the boxes next to the slider with the
following controls:
•

Density – adjusts the amount of transparency of the image from 0-100% (this
must be viewed on the 5420 module output).

•

X Position – adjusts the horizontal positioning of the image.

•

Y Position – adjusts the vertical position of the image.

You can also use the mouse to drag the image to change its position on the screen.
The main screen will display the image at 640 x 486 square pixels. The image can be
scaled for a 525 or a 625 line rate during the download or set for no scaling as explained
in the Downloading Images To The 5420 Module section later in this data pack. The
boxes to the right of the X and Y Position will show the actual position of the image
when the image is scaled to the selected standard (525 or 625).
You can display a safe title guide for positioning the graphic by enabling the Markers
option at the lower left of the main screen. This will show markers that indicate the safe
areas of the screen where images will appear on a broadcast signal.

Pixel Scaling In Television Graphics Versus Computer Graphics
It’s commonly known that graphics created and displayed on personal computers use a
square pixel format. In contrast, the television world uses a rectangular pixel format. For
this reason, graphics created on computer must be scaled in order to retain their proper
appearance when output to video.
The Pixel Scaling pulldown in the main screen provides you with either automatic pixel
scaling, or non-pixel scaling options, depending on your needs:
•

NTSC 640 x 486 Sq Pix – choose this to automatically scale computer-generated
graphics for 525 NTSC output. This is the most common choice for NTSC applications.

•

PAL 786 x 576 Sq Pix – choose this to automatically scale computer-generated
graphics for 625 PAL output. This is the most common choice for PAL applications.

•

NTSC 720 x 486 – choose this if your graphics do not need automatic scaling or
are already scaled for 720 x 486 NTSC (4:3) output.

•

PAL 720 x 576 – choose this if your graphics do not need automatic scaling or are
already scaled for 720 x 576 PAL (4:3) output.
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Creating Logos
To gather graphics or animation graphics for collection as logos in a project file, begin by
defining each logo (1 – 999). The application will start with Logo 1 as shown in the main
screen.
On the main screen, click the ... button next to the File Name box or select Load TGA
Image from the File pulldown menu in the upper left corner to bring up the Get Image
screen shown below.

To load a single .tga (targa) file as Logo 1, browse to the stored image folder and select the
file so it appears in the Input File box and click OK. The logo file name will appear in
the File Name box on the main screen. Create an identifying name for this logo by typing
a name in the Logo Name box.
The logo image will appear in the main screen display and will also display fill and key
information on the left of the screen. If the image includes a key (alpha) channel, both
images will appear in the Fill and Key boxes as shown in the example on the main screen.
You may also create a key channel if none exists by enabling the Self-Key function using
the Adjust Key Settings function explained later.
To delete a logo, select the logo number and select the File pulldown menu in the upper
left corner of the main screen. Choose Delete Current Logo from the pulldown list. The
current logo will be deleted.

Get Image Screen
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If the image to be loaded is an animation sequence, select all of the animation files in the
group at once (select the top file, hold down the Shift key and select the last file in the
sequence) from the Get Image screen. Refer to the Get Image screen shown below. Note
that each file in a sequence must be the same size, named the same, and numbered in
sequence. The last file selected will appear in the Input File window. Select OK to load
the sequence to the main screen.
In the main screen, the Count box will show the number of files in the sequence and the
Cycle control will be enabled. Set the animation to cycle as follows:
•

Once – the animation will play once and stop at its end.

•

Loop – the animation will play continuously from beginning to end in a loop.

•

Ping Pong – the animation will play from beginning to end, then from end to
beginning continuously.

You can view the animation sequence in real time by selecting Show Animation on the
main screen. The sequence will play in whatever format you have chosen with the Cycle
control. The frames per second (FPS) of the animation will be reported next to the Show
Animation box.

Get Animation Sequence Images
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Adjusting Crop Settings
A logo can be cropped to eliminate an unwanted portion of the graphic or to select a
specific part for downloading. To crop a logo, load the image into the main screen and
click the Adjust Crop Setting button to display the Crop Image screen shown below.

Crop Image Screen
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Use the cursor to select the portion of the graphic to crop as shown below. The cropped
portion of the graphic will be grayed out. The portion of the graphic that will be downloaded
appears in the Preview box (lower left) along with its size in pixels. You can use the Zoom
In and Zoom Out controls to change the viewing size of the graphic. To return to the
original graphic, select Reset Crop Settings.
When you have the image you want, select Accept to save the settings. Note that the
original graphic file will not change. Only the portion you have selected that is displayed
in the Preview box will be downloaded for this logo.

Cropped Graphic Example
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Adjusting Key Settings
You can also make key setting adjustments to an image or create a key (alpha) channel if
none exists. To adjust the key settings of an image loaded in the main screen or to create
a key channel, click the Adjust Key Settings button in the main screen.
In the example below, a foreground signal is self-keyed to create a key channel from the
graphic foreground. To create a key channel, select the Self-Key box. Adjust the Clip and
Gain Adjustment sliders, or enter a value in the boxes to the right for the desired key.
You can invert the key by selecting Invert Key. A key and fill signal will now be present
with the fill matching the key signal exactly.
The Shape Fill box can be selected when separate key and fill signals are part of an
image and need to be adjusted. The 5420 module uses a linear additive keyer and requires
that key and fill match exactly for a correct key. When Shape Fill is selected, the key fill
in a selected image will be shaped to match the key signal.
Preview the key by selecting Show Key. The graphic can be displayed with a background
grid by selecting Show Background Grid. To see the graphic at full size, select Show
Actual Size.
To save the adjustments for download, select Accept or Cancel to close without changes.
The original graphic file will not change and only the changes in the Preview view will
be downloaded.
You can also use this screen to adjust a graphic with both key and fill for the desired key
effect.

Key Channel Adjust Screen
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Creating, Saving, and Loading Projects
Once you have defined all the logos for a particular project, save the group to a project
file. Open the File pulldown menu on the main screen as shown below and select Project.
Select Save. When the Save As dialog appears, name and save the project file (.LCF) to
the Avenue Logo folder or browse to another location if desired.
To delete the current project or create a new one, select New.
To load a project for download to the 5420 module, select Project from the File pulldown
and select Load. When the Open dialog appears, locate the file you wish to download and
click Open. This will bring the project to the main screen where you can view or change
any logos if needed.

File Pulldown Menu on Main Screen
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DOWNLOADING IMAGES TO THE 5420 MODULE
Once a project is selected for downloading and loaded to the main screen, use the Pixel
Scaling pulldown to select the desired graphic scaling option. (See page 4 for an explanation of pixel scaling.)
Next, select Download to Module from the File pulldown. A Status popup will indicate
the project being loaded. When complete, the Download screen will appear.
In the Frame Com box, select the type of connection you will be using to connect the PC
to the Avenue frame or Touch Screen. Choices are:
•

Network – for a network connection, enter the IP address of the Avenue frame that
contains the 5420 module you wish to download to. (This is the recommended option.)

•

Serial – for a serial connection, select the Serial Port (COM 1–4) you will be
using on the PC.

When the connection is made, the Frame Com and Network LED indicators on the
bottom of the Download screen will illuminate green.

Avenue Logo Download Screen
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Next, click the Get Module List button to search for all the Avenue frames and modules
on the network and load them into the Frame Select and Module Select pulldown
menus. From the Frame Select pulldown, locate the Avenue frame on the network that
contains the 5420 module you wish to download to. Then, from the Module Select
pulldown, select the 5420 module in the chosen frame.
Note: Downloading this project will erase the current project in the selected 5420
module. Make sure the 5420 you have selected is off-air before downloading.
Once the frame and module are selected and frame communication is active, click the
Download Now button. The download will begin by first erasing the current project
loaded in the selected 5420 module. This process will take about 40 seconds and erase
time remaining will appear in the lower left corner.
When the download begins, the progress boxes below the frame and slot pulldowns will
show the overall download progress and the progress of each file as it downloads. The
Sent and ACK boxes will also indicate download progress and the remaining download
time will appear in the lower left corner of the window.
Once the download is complete, click the Done button. If you wish to stop the download,
click the Abort button.

HELP MENU

The Help pulldown menu on the main screen shown above displays a Contents selection
to open this manual in pdf format and an About... popup indicating the current software
version and the serial number of the Avenue Logo application.
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WARRANTY AND FACTORY SERVICE
Warranty
Ensemble Designs, Inc. warrants this product to be free from defect in material
and workmanship for a period of two years from the date of delivery. During this
two year warranty period, Ensemble Designs, Inc. will repair any defective units
at Ensemble’s expense if the unit should be determined to be defective after
consultation with a factory technician.
This warranty is not transferable. Any implied warranties expire at the expiration
date of this warranty.
This warranty does not cover a defect that has resulted from improper or unreasonable
use or maintenance as determined by us. This warranty is void if there is any
attempt to dissemble or adjust factory set presets without factory authorization.
Factory Service
If you require service (under warranty or not), please contact Ensemble Designs
and ask for Customer Service before you return the unit. This will allow the
service technician to provide any other suggestions for identifying the problem
and recommend possible solutions.
You may also refer to the technical support section of the Ensemble web site for
the latest information on your equipment at the URL below:
http://www.ensembledesigns.com/support
If you return equipment for repair, please get a Return Material Authorization
Number (RMA) from the factory first.
Ship the product and a written description of the problem to:
Ensemble Designs, Inc.
Attention: Customer Service RMA #####
870 Gold Flat Rd.
Nevada City, CA 95959 USA
(530) 478-1830
Fax: (530) 478-1832
service@ensembledesigns.com
http://www.ensembledesigns.com
Be sure to put your RMA number on the outside of the box.

Avenue Logo-13

